IP address problem

Discussion related to NP Subscriber Pro.

IP address problem

Postby jojomart » Fri Apr 20, 2007 12:16 am

Hi again,

I'm trying to get the form generator to work, but each time, I get an error message saying that my IP has changed and I have to log in again.

No matter how many times I try to log in, it still won't let me get the html. It says you must reset the ip address on record.

I checked the file on the site, and the ip is correct - I'm accessing it from the same computer I installed it on, so I can't figure out what the problem could be.

Can you please help me?

Thanks,
Joanne
jojomart
 
Posts: 2
Joined: Thu Apr 19, 2007 11:47 pm

Postby Admin-BS » Fri Apr 20, 2007 10:27 am

This has seemingly become a bit of a common problem, apparently. I honestly do not know the cause of it. There is honestly nothing special about running the plugin, and if you don't have problems with the verification on any other functions, you shouldn't have a problem there.

Are you running it in subscriber.cgi or admin.cgi? You should be running it in subscriber.cgi, but I don't think that that would cause this problem.

Sorry I can't be more helpful at this point...
Admin-BS
Site Admin
 
Posts: 99
Joined: Sat Dec 31, 2005 6:52 pm
Location: USA

Fix

Postby skipper3 » Fri Apr 27, 2007 9:33 pm

You can fix this by simply changing subscriber.cgi line 294 as follows:

OLD: else {&ip_wrong; exit;}
NEW: else {print "";}

This will remove one level of security (IP Check), however the admin area is password protected. Many people work from home or have service providers that have dynamic IP addresses so this can be annoying.
skipper3
 
Posts: 3
Joined: Fri Apr 27, 2007 9:32 pm


Return to Subscriber Pro

Who is online

Users browsing this forum: No registered users and 0 guests

cron