Page 1 of 1

Installation Error

PostPosted: Wed Jan 10, 2007 7:29 am
by zebra4
Hi,

I'm trying to install the pro version, but I'm getting the following error after executing the firstrun.cgi script.

Software error:
vars.txt did not return a true value at /home/xxx/cgi-in/nwslet/firstrun.cgi line 167.

However, the vars.txt file has been created, it's listed in the same directory.

I've previously succesfully installed the basic script on another domain.

What am I doing wrong? Thanks in advance for your help.

Steven

PostPosted: Wed Jan 10, 2007 9:35 am
by Admin-BS
Is there actually anything within the vars.txt file? If it is blank then it is not going to be returning a value when it is required in the script.

Also, if you simply load up subscriber.cgi in your web browser, do you get a similar error?

PostPosted: Tue Jan 16, 2007 8:17 am
by zebra4
Yes, vars.txt contains all variables, it isn't empty.
I get the same error when trying to access admin.cgi.

There was a problem on the server. All txt files belonged to "nobody" and couldn't be accessed. This now has been changed and permissions were set manually to 777. But the problem still occurs.

PostPosted: Tue Jan 16, 2007 4:57 pm
by Admin-BS
The only possibilities I can imagine that would still cause the error are:

1) The file still cannot be read. Check that the owner of the file is actually the user that executes scripts (this may not be your username... even on some shared hosting).

2) There is a problem within the vars.txt file itself (such as a quote somewhere that wasn't properly escaped). Try running the firstrun.cgi script from the beginning again, without editing anything that isn't necessary. You should only really need to enter the URLs to the scripts and the password for the script to fully function.